Language

Login to Openmtbmap

email feed

Install Garmin Mapsource and/or Basecamp

Install Mapsource without owning a Garmin Device

There are several programs to display openmtbmaps on your PC/notebook. The most popular is still Garmin Mapsource – even though it is superseeded by Garmin Basecamp and also Qlandkarte GT is on the way to overtake it. Garmin Mapsource is not develloped anymore, but version 6.16.3 runs still pretty well and has no big bugs. There is a catch however. Garmin only provides updates, no actual installation packages. Therfore below I describe two ways how you can install Mapsource legally nevertheless.

People who have bought a Garmin GPS will have a CD shipped with it including Mapsource.  I recommend to use the most uptodate version by Garmin (as of writing this is 6.16.3)

Earlier versions of Mapsource (also 6.13.6) are now incompatible with the openmtbmaps as they do not show all ways and streets!!!! Use at least 6.16.1 or higher. Note that while Basecamp shows contourlines, Garmin Mapsource doesn't. Hence for general use I recommend Garmin Basecamp instead.

 

Classic Way of Installation without already having Mapsource installed (please install everything as administrator)

I recommend installing a second map (good idea is to install the map legend so you can get to know the layout!!!) because you need to have two maps installed before the map selector shows up. Essentially 1 map would be enough also.

 

Advanced Way of Installation without already having Mapsource installed

  1. First install at least one openmtbmap (just run the .exe)
  2. Attention, Mapsource will not install correctly until you have a at least one map installed. So if you forgot step 1, do it now! Go to  http://openmtbmap.org/download/ and download the map(s) of your choice and install at least one map!
  3. Download  latest MapSource from Garmin ( http://www8.garmin.com/support/download_details.jsp?id=209 ).
  4. Unpack or extract the content of setup_MapSource.exe using 7zip (www.7zip.org), WinRAR or another good unpacker.
  5. From the extracted files, first run MAIN.msi.
  6. Then, run Setup.exe.  Note: The sequence to execute Main.msi and then Setup.exe is important to avoid “Previous MapSource not found!” error.
  7. Garmin MapSource is now installed. I recommend installing a second map (good idea is to install the map legend so you can get to know the layout!!!) because you need to have two maps installed before the map selector shows up.

Note I still recommend to install Garmin Basecamp nevertheless: Get it here: http://www.garmin.com/garmin/cms/us/onthetrail/basecamp

 

Attention Mapsource 6.13 6.14 and 6.15 Users:

Please update to at least 6.16.1 — earlier Mapsource versions miss a lot of ways and streets and make the maps unusable.

 

Parallel installation of several Mapsource versions:

Simply unpack a mapsource update (see links above), run MAIN.msi and then rename mapsource.exe to something else. e.g. mapsource_6.13.6.exe and then copy it into your main Garmin Mapsource installation folder (usually c:/garmin). Now you can decide which of the two versions you want to use.

 

 

34 comments to Install Garmin Mapsource and/or Basecamp

  • Ciliberto

    I installed the france and italy on my MAC OS and I use basecamp.
    Everything is working fine except that when I use your map and I create a path starting from a created itinerary the total climbing is not given.
    Whereas if I use a map of Garmin the total climbing is computed.
    Is there a specific set-up that I should do when I create an itinerary using your maps ?
    Thank you for your answer

    • extremecarver

      Nope, that’s not possible because the maps have no DEM. Only for routes you can have the ascent. However you can after creating the track, quickly convert it to a route (direct routing) to see the altitude profile.

  • nani50

    OK, danke für die schnelle Antwort. Habe jetzt BC installiert, scheint alles zu funktionieren. Kurze Frage: Gibts da auch irgendwo so ein Fadenkreuz wie bei MS? Ich find nichts….
    vielen dank nochmal
    nani50

  • nani50

    Hi,
    ich hatte bisher eine ältere funktionierende MS Version,die ich mal zusammen mit einem Garmin Navi bekommen hatte. Ich hab ein Update ausgeführt, nur hat MS dann nicht mehr gestartet Fehler: Runtime error.
    Kein Problem, dachte ich, und hab gemäß o.e. Anweisung MS neu installiert. Dabeiu gab es keine Fehlermeldungen oder Hinweise. Jetzt startet MS nicht mit dem Fehler “incorrect language file, Please reinstall MS” Das hab ich getan, ich hab dann auch mal alles deinstalliert und neu gemacht, der Fehler bleibt.
    Ich fahre WinXP
    Jemand eine Idee?
    Vielen Dank

  • wattwurm25

    So leid es mir auch tut, aber auch nach dieser Beschreibung bekomme ich ws einfach nicht hin. Ich weiß einfach nicht mehr weiter . Habe die angeforderten Dateien ruuntergeladen aber die Karten lassen sich einfach nicht anzeigen

  • Werner Menke

    Hallo, ich habe die Karten von Deutschland und den Alpen runtergeladen. Leider habe ich zur Zeit keinen eigenen PC o. Laptop mir dem geeigneten Betriebssystem f. BaseCamp. Kann ich die Karten auch direkt auf die SD-Karte von meinem EDGE 705 senden?

  • Giaxy

    RAGAZZI SE QUALCUNO MI RIESCE AD AIUTARE PERCHE’ NON RIESCO A FAR LEGGERE LE MAPPE DI OPENMTB NE SU BASE CAMP NE SU DAKOTA 20. ADESSO STO PROVANDO AD INSTALLARE MAP SOURCE MA CREDO CHE NON SIA QUESTO IL METODO. C’è QUALCUNO CHE MI Può AIUTARE ? GRAZIE INFINITE.

  • Heinz Schanbacher

    Hallo,
    ich habe mir Polen heruntergeladen. In Mapsource ist das Grenzgebiet zu Deutschland einwandfrei. Nach Installation auf meinem Garmin Oregon 450 fehlen an der Grenze zu Deutschland mindesten 30 km in denen kein Objekt zu sehen ist. Danach richtung Osten ist alles ok. Ähnliches ist auch bei der Karte Czechien im Bereich Liberec. Hier sieht man aber wenigstens die Höhenlinien.
    Wie kann man das beheben?

  • miso

    Hallo,

    bin hier gerade neu eingestiegen mit meiner Registrierung und möchte mich erstmal für diesen tollen Service bedanken, an solche tollen aktuellen Karten zu kommen. Funktioniert bei mir auch alles klasse, bis auf ein Problem (wahrscheinlich bin ich dieses) mit Basecamp. Die Karten habe ich in einen Ordner auf meiner Festplatte geladen, bekomme sie aber nicht in Basecamp aufgerufen. Finde dort keinen Menüpunkt, mit dem ich auf irgendeinen Ordner zu greifen kann. Wenn ich aber das Navi oder einen USB-Stick mit den Karten anschließe, findet Basecamp die bereits beim Hochfahren, Damit funktioniert’s also bestens. Wo hapert’s denn bei mir?

    Allerbeste Grüße
    Michael

    • extremecarver

      Das ist normal. Es ist eine Sonderfunktion von Basecamp, Karten von USB Stick oder als extern gekennzeichneten Laufwerken besonders zu behandel. Am PC müssen die Karten installiert werden – damit Basecamp sie findet. Installiert (also .exe ausführen) sollten sie aber sofort in Basecamp im Map Selector auftauchen – evtl musst du den erst der Toolbar hinzufügen.

  • Jsteinwede

    Servus, habe letzte Woche die neue Europakarte runtergeladen. Nutzen der Karte ist soweit auf kein Problem, genausowenig wie schicken von Kacheln an mein Edge. Aber was nicht funktioniert ist die “layout-ändern-Anwendung”. Da beschreibt sich mein Rechner immer. Habe die exe bereits mehrfach neu installiert. Bei der velomap gibts denselben Fehler. Kann man bei der Installation irgendwas falsch machen?

    Grüße!

    • extremecarver

      was passiert wenn du die change layout country.exe aufrufst? Mapsource/Basecamp müssen auf jeden Fall dabei geschlossen sein. Alternativ könntest du auch drüberinstallieren – und dabei ein anderes Layout auswählen.

  • mbrennic

    Hallo,

    Ich denke das ist jetzt nicht wirklich ein Drama, aber wie bekomme ich denn, mit der aktuellen Basecamp version und den Velokarten die Contourkarte mit auf meine Speicherkarte (im Edge 800).

    Das kartenauswaehlen und Ueberspiel funzt, aber ich kann nirgends die Contouren hinzu addieren? geht das nur bei MTB karten?
    contourfiles sind im gleichen Verzeichnis wie die maps.

    Danke
    Gruss
    Marc

  • Ronny H.

    BaseCamp läuft jetzt und zeigt alle Karten ordentlich an.
    MapSource läuft weiterhin nicht…kann alle Karten anwählen, Städte oder POIs suchen allerdings bleibt alles gelb.

    Gruss Ronny

  • Ronny H.

    Also in Trainingscenter zeigt er alles an Karten an wie es sein soll, liegt also dann an MapSource oder weiss der Geier was. Wie lang sietz ich jetz hier ? 13 Stunden.
    Kann es damit zusammen hängen das ich Windows XP mit VMware Fusion auf dem Mac OS Lion laufen lasse? Dürfte eigentlich ja nicht, denn es ist ja nichts anderes als wenn Win XP nativ läuft, alle anderen Programme laufen ja auch unter Windows.
    Nun hätte ich noch die Möglichkeit zu versuchen die Europa Karte direkt unter OS Lion zum laufen zu bekommen, nur nach dem ich so viel gelesen habe erscheint mir das alles noch viel komplizierter als es auf Win zum laufen zu bekommen.

    Danke für den Support, ich nerve echt ungern und lese mich auch ein, aber ich find nicht die Stelle wo ich ein Fehler mache.

    Gruß Ronny

  • Ronny H.

    Ich kann jede Stadt suchen, z.B. Berlin oder München, kann mir auch bestimmte POI anzeigen lassen, aber da steht dann eben nur zB Theater auf der Karte und drum herum egal ob zoom 50 m ode 5 km ist und bleibt alles gelb, es wird absolut nichts angezeigt.

    Gruß Ronny

    • extremecarver

      Schau mal ob die .img Dateien, auch wirklich in dem Installationsordner liegen. Mir kommt es so vor als würden die irgendwie fehlen (evtl eine Rechteproblem beim Installer??). Was ist wenn du Basecamp ausprobierst?

  • Ronny H.

    Kurzer Nachtrag, ich habe nun auch durch Doppelklick die “Legend” Karte installiert, kann nun in Map Source zwischen der germany und der legend Karte oben Links wählen, jedoch auch hier ist egal in welcher Zoom Stufe alles gelb.

    Mir unbegreiflich was ich falsch machen soll.

    Gruß Ronny

    • extremecarver

      Normalerweise solltest du mit der Suchfunktion, den Kartenausschnit finden. Alternativ, downloade irgendeinen Track oder POI aus Deutschland im Internet, dann aktiviere die Deutschlandkarte, und gehe beim Track auf “Track auf Karte zeigen” oder so ähnlich. Evtl befindest du dich irgendwo in der Prärie (bzw halt per Koordinaten nach Deutschland finden).

  • Ronny H.

    Hallo,

    ich schreib jetzt hier was ich gerad genau tue. Ich habe alles gelöscht, Ordner wie “Garmin” das Programm BaseCamp3 (was sowieso nicht lief) MapSoure wurde auch gelöscht.

    1. Ich habe die komplette Karte von Deutschland gedownloadet
    2. Ich installiere diese durch Doppelklick, das vorgeschlagene Installationsverzeichnis behalte ich bei, dies ist: C:\Garmin\openmtbmap\germany

    3.Im Trainingscenter sehe ich die Deutschland Karte ohne Probleme
    4. ich installiere durch Doppelklick MapSource_6163.exe
    5. ich kann auch mit dieser Art der installation zwar die Karte “germany” anwählen jedoch ist alles gelb.

    Ich kann zwar unter Ansicht/Zu Produkt wechseln die Karte “openmtbmap_germany….” anwählen jedoch wird nichts angezeigt, es bleibt gelb, egal in welcher Zoom Stufe. Also das gleiche wie bei der Europa Karte.

    Weiss mir kein Rat mehr.

    Gruß Ronny

  • Ronny H.

    Hallo,

    ich habe ja nun heute auch 20 Euro überwiesen. Ich sitze nun seit Stunden vor meinem Rechner und bekomme absolut nichts hin. Ich habe nun 3 mal die oben genannten Schritte durchgeführt, leider zeigt mir Mapsource nichts an.
    Um genauer zu werden, Im Garmin Trainings Center wird mir die Europa Karte angezeigt, ohne Probleme. Starte ich aber MapScource und wähle die Karte Europa aus, bleibt alles gelb. gebe ich unter Suche eine Stadt ein findet er die auch, aber es wird nichts angezeigt, alles gelb. Ich auch verschiedene Typs eingestellt zuletzt bei Neuinstallation “Classic”, aber es bleibt einfach gelb. Sicher liegt der Fehler bei ir, nur was kann ich noch machen?

    Würd mich über Hilfe freuen,

    Vielen Dank

    Gruß Ronny

    • extremecarver

      Versuchs erstmal mit einer normalen Länderkarte. Wobei ich sicher bin, dass du bei der Europakarte, die .7z Dateien, einfach an den falschen Ort entpackt hast (lass den Installer nochmal laufen, merk dir das Verzeichnis, und in dem Verzeichnis (nicht in einem Unterverzeichnis) müssen dann auch die .img liegen)…..

Leave a Reply